‘id’ is a bad variable name in Python

id() is a fundamental built-in:

Help on built-in function id in module
__builtin__:

id(...)

    id(object) -> integer

    Return the identity of an object.  This is guaranteed to be unique among
    simultaneously existing objects.  (Hint: it's the object's memory
    address.)

In general, using variable names that eclipse a keyword or built-in function in any language is a bad idea, even if it is allowed.

Leave a Comment