Visual Studio does not let me drag drop items into it?

On Windows Vista and newer Windows Explorer runs with medium integrity level. If you run Visual Studio as administrator (high integrity level) then for security reasons OS will disable drag and drop from Explorer to Visual Studio. You can either run Visual Studio as normal user or you can install VSCommands for Visual Studio 2012 … Read more

How to set SGEN toolpath in Msbuild to target 3.5 framework

I have solved this by manually configuring the ToolPath to point to the old (version 2.0.50727.3038) version of sgen.exe On my machine, this is in: C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin I changed the ToolPath attribute to be: ToolPath=”C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin” and this solved the problem. It seems, by default, it’s running the new 4.0 framework … Read more

This project references NuGet package(s) that are missing on this computer

In my case, I had to remove the following from the .csproj file: <Import Project=”$(SolutionDir)\.nuget\NuGet.targets” Condition=”Exists(‘$(SolutionDir)\.nuget\NuGet.targets’)” /> <Target Name=”EnsureNuGetPackageBuildImports” BeforeTargets=”PrepareForBuild”> <PropertyGroup> <ErrorText>This project references NuGet package(s) that are missing on this computer. Enable NuGet Package Restore to download them. For more information, see The missing file is {0}.</ErrorText> </PropertyGroup> <Error Condition=”!Exists(‘$(SolutionDir)\.nuget\NuGet.targets’)” Text=”$([System.String]::Format(‘$(ErrorText)’, ‘$(SolutionDir)\.nuget\NuGet.targets’))” /> … Read more

How to set CUDA compiler flags in Visual Studio 2010?

You can select the options for the GPU Code Generation in this dialog: In this case “compute_20” means that i am compiling for the virtual compute architecture 2.0 – virtual architecture influences the PTX generation stage. The second part that comes after the coma is “sm_21”.This influences the CUBIN generation stage. It defines the real … Read more