Naming Classes – How to avoid calling everything a “Manager”? [closed]

I asked a similar question, but where possible I try to copy the names already in the .NET framework, and I look for ideas in the Java and Android frameworks.

It seems Helper, Manager, and Util are the unavoidable nouns you attach for coordinating classes that contain no state and are generally procedural and static. An alternative is Coordinator.

You could get particularly purple prosey with the names and go for things like Minder, Overseer, Supervisor, Administrator, and Master, but as I said I prefer keeping it like the framework names you’re used to.


Some other common suffixes (if that is the correct term) you also find in the .NET framework are:

  • Builder
    A type that use some parameters to construct an instance of a special type. Builder is usually a throwaway. It may not even need to allocate a variable.
    If the type needs to repeatedly create objects, please use Factory.
    if the type responsible for create multiple different type objects, please use Factories.
  • Writer
    Write some variable into something.
  • Reader
    Read something as variable.
  • Handler
    Designed to deal with a situation or something.
  • Container
    Can put something into it.

Leave a Comment